Hola a todos!

Con la nueva versión de prestashop nos hemos encontrado con el siguiente error al intentar actualizar nuestros módulos:

 [PrestaShop] Fatal error in module install-1.3.2

Este problema ocurre por un bug en el modulo homeslider, para solucionarlo solo debemos comentar una de la lineas de los archivos de este módulo.

En la carpeta modules/homeslider/upgrade/install-1.3.2.php debemos comentar la línea 9, debe quedar de esta manera:

<?php

if (!defined(‘_PS_VERSION_’))
exit;

function upgrade_module_1_3_2($module)
{
if (Tools::file_exists_cache($module->getLocalPath().’images’))
#Tools::recurseCopy($module->getLocalPath().’images’, $module->getLocalPath().’img’, true);

Tools::clearCache(Context::getContext()->smarty, $module->getTemplatePath(‘homeslider.tpl’));

return true;
}

Con esto ya podremos actualizar nuestros módulos.