¡Buenos días Wecindario! ¿Tenéis un PrestaShop 1.7 y lo notáis lento? A ver si estos apuntes sobre PrestaShop 1.7.4.3 os sirve de ayuda. Desde luego que para mí si fueron útiles y con ello, decidí ponerlo en nuestro blog.

Las mejoras y las correcciones


El PrestaShop 1.7.4.2  lleva corregido el problema de la lentitud en la API.

Para el PrestaShop 1.6.1.20 se han solucionado 5 errores :

  • El problema del núcleo que impide el acceso a los recursos remotos.
  • Solucionado el error la cual la información podía revelarse cuando se producía un error fatal.
  • Se ha solucionado el problema por los spammers explotaban el formulario de contacto y enviaban spam.
  • El bloqueo al intentar enviar un correo electrónico a una dirección que contenía caracteres no compatibles.
  • Solucionado el problema de escalada de privilegios en el que un usuario registrado en el BackOffice podría ejecutar código arbitrario en el sistema

Los requisitos del PrestaShop 1.7.4.3


Para que PrestaShop funcione correctamente se debe tener en cuenta estos requisitos:

  • Versión PHP mínima: 5.6.3
  • Accelerators: No requerido
  • magic_quotes_gpc: off
  • memory_limit: 512M
  • max_execution_time: 300
  • max_input_time: 300
  • upload_max_filesize: 20M
  • post_max_size: 20M
  • max_input_vars: 10000
  • allow_url_fopen: on (Activado permite importar imágenes).
  • safe_mode: off
  • cURL:Instalado
  • mod_rewrite: instalado y activado.
  • mod_security: off
  • JSON: ON
  • ctype: ON
  • mySQL: 5.7 o superior (mejor con mariaDB).
  • mySQL: INNODB (myIsam no funciona muy bien).
  • php.ini: (Debe incluir date.timezone).
  • Open SSL: Versión 1.0.2 o superior.
  • Servidores: Linux (Prestashop no es recomendable para servidores de Windows/IIS).
  • cageFS y otro Firewall técnico en el servidor configurado correctamente para que en el backoffice no sea muy lento el bloquear los servicios externos que usa Prestashop.
  • suhosin.request.max_vars = 20000 o superior.
  • suhosin.post.max_vars = 20000 o superior.
  • max_input_vars = 20000 o superior

Si quieres, se recomienda esta configuración para OPcache:

Recomendaciones para OPcache

  • opcache.revalidate_freq = 0
  • opcache.validate_timestamps = 0
  • opcache.max_accelerated_files = 7963
  • opcache.memory_consumption = 192
  • opcache.interned_strings_buffer = 16
  • opcache.fast_shutdown = 1

PrestaShop 1.7.4.3

Cómo actualizar a PrestaShop 1.7.4.3


Cómo siempre os digo, antes de actualizar tu Tienda, o cualquier cosa, realiza una copia de seguridad ¿sabes cómo?

  1. Desde Plesk comprueba que los archivos y carpetas de la web de PrestaShop tiene los permisos adecuados (755, 644).
  2. Accedemos al BackOffice
  3. Vamos a Personalizar, Módulos, Módulos instalados.
  4. Revisamos que tienes instalado el módulo “1-Click Upgrade” (Actualización en 1-Clic) versión 4.0.0.
  5. Si el módulo está instalado, accedemos directamente a Más, 1-Click Upgrade.
  6. Activamos el Modo Mantenimiento, de lo contrario no podrás actualizar.
  7. Revisamos en Comenzar Actualización que existe una versión nueva disponible superior a la instalada.
  8. Haz clic en el botón ¡ACTUALIZAR PRESTASHOP AHORA!
  9. Esperamos a que acabe.
  10. Cuando termine hacemos clic en el menú izquierdo Inicio.
  11. Accedemos de nuevo al administrador, ya que podrás comprobar que te ha sacado de la sesión.
  12. Desactivamos el Modo Mantenimiento
  13. Vamos a configurar en parámetros Avanzados, Rendimiento y haz clic en Borrar la caché.
  14. Comprobamos el funcionamiento de todo de la tienda

Si todo funciona ¡Felicidades! ya has actualizado a una versión estable.

Esto es todo Wecindario, con esta actualización ya deberías notar más rápido el PrestaShop gracias a la actualización insertada de PrestaShop 1.7.4.3. ¿Os ha servido de ayuda? ¡Compartid!

Accede a más contenido

En Hoswedaje, ofrecemos más contenido sobre por qué debes actualizar PHP. No obstante, te dejamos otro artículo relevante acerca de UTF-8 y en qué consiste. Si tienes alguna duda o cualquier consulta, ponte en contacto con nosotros y te lo resolveremos con la mayor brevedad posible.

impuestos en mi PrestaShop Aprende por qué debes actualizar PHP, leyendo esta entrada que te dejamos reflejada.

impuestos en mi PrestaShop  Descubre en qué consiste UTF-8, pinchando en este enlace.